【通达信循环指标】相关内容

  • 通达信指标

    匿名用户5723评分

    这什么意思啊

  • 怎样把这个指标改成通达信?

    匿名用户4564评分

    L0循环调用不知道怎么解决。

    GAMMA:=0.66;


    L0 := (1 - GAMMA)*C + GAMMA*REF(L0,1);

    仅就L0来说,变:

    GAMMA:=(1-0.66);


    L0 :=DMA(C,GAMMA);

  • 通达信 指标 多个条件排列组合输出不同结果应该怎么编

    匿名用户3471评分

    AB的条件我随意设置的。
    A:=BARSLASTCOUNT(C>MA(C,20))>5;
    B:=BARSLASTCOUNT(C>MA(C,60))>5;
    IF(A>0,A,0);
    IF(B>0,B,0);
    AB:A+B;
    IF(A>0 AND B>0,AB,0);

  • 通达信这个指标怎么用?

    匿名用户2444评分

    RSV=(收盘价-N1日内最低价的最低值)/(N1日内最高价的最高值-N1日内最低价的最低值)*100
    K=RSV的N2日[1日权重]移动平均
    D=K的N3日[1日权重]移动平均
    输出J:3*K-2*D
    输出SZ:100
    输出XZ:0
    输出MA6:J的M日简单移动平均
    输出MA60:J的M1日简单移动平均N1=60
    N2=3
    N3=3
    M=6
    M1=60

  • 求通达信缠论精确笔主图画线公式

    匿名用户1484评分

    {精确缠论中枢公式}
     
    {N1:1,100,10;N2:1,100,10;DISP:=1,3,2};
    n1:=10;
    n2:=10;
    DISP:=2;
    N1:=10;N2:=10;DISP:=2;
    K:=IF(PERIOD=5,1,{日}
    IF(PERIOD=6,1,{周}
    IF(PERIOD=7,1,{月}
    IF(PERIOD=8,1,{多分钟}
    IF(PERIOD=9,1,{多日}
    IF(PERIOD=10,1,{季}
    IF(PERIOD=11,2,{年}
    IF(PERIOD=4,1,{60F}
    IF(PERIOD=3,1,{30F}
    IF(PERIOD=2,1,{15F}
    IF(PERIOD=1,1{5F},1{1F})))))))))))/10;
    P1:=PEAK(1,K*N1,1);
    P2:=PEAK(1,K*N1,2);
    WP1:=PEAKBARS(1,K*N1,1);
    WP2:=PEAKBARS(1,K*N1,2);
    T1:=TROUGH(2,K*N2,1);
    T2:=TROUGH(2,K*N2,2);
    WT1:=TROUGHBARS(2,K*N2,1);
    WT2:=TROUGHBARS(2,K*N2,2);
    TJ1:=P1>T1 AND P2>T2 ;
    ZD:=MAX(T1,T2);
    ZG:=MIN(P1,P2);
    LL:=MIN(T1,T2);
    HH:=MAX(P1,P2);
    TJ2:=FILTER(ZG>ZD,2);
    TJ3:=ZG=REF(ZG,BARSLAST(TJ2)) OR ZD=REF(ZD,BARSLAST(TJ2));
    TJ4:=TJ1&&TJ2&&NOT(TJ3);
    TJ5:=BETWEEN(ZD,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
    TJ6:=BETWEEN(ZG,REF(ZD,REF(BARSLAST(TJ4),1)),REF(ZG,REF(BARSLAST(TJ4),1)));
    TJ7:=ZG>REF(ZG,REF(BARSLAST(TJ4),1))&&ZD<REF(ZD,REF(BARSLAST(TJ4),1));
    TJ8:=TJ4&&NOT(TJ5 OR TJ6 OR TJ7);
    ZSD:=IF(TJ8,ZD,DRAWNULL);
    ZSG:=IF(TJ8,ZG,DRAWNULL);
    ZSH:=IF(TJ8,HH,DRAWNULL);
    ZSL:=IF(TJ8,LL,DRAWNULL);
    STICKLINE(TJ8,ZSH,ZSL,0,-1),COLORMAGENTA;
    STICKLINE(TJ8,ZSD,ZSG,IF(DISP=1,3,0),1),COLORMAGENTA;
    DRAWTEXT(DISP=2,ZSH,'中枢'),COLORWHITE;
    中枢高:PLOYLINE(DISP=2,REF(ZSD,BARSLAST(TJ8))),CIRCLEDOT,COLORLIRED;
    中枢低:PLOYLINE(DISP=2,REF(ZSG,BARSLAST(TJ8))),CIRCLEDOT,COLORLIGREEN;
    {中枢最高:PLOYLINE(DISP=2,REF(ZSH,BARSLAST(TJ8))),POINTDOT,COLORRED;
    中枢最低:PLOYLINE(DISP=2,REF(ZSL,BARSLAST(TJ8))),POINTDOT,COLORGREEN;}
    趋势高:PLOYLINE(DISP=3,ZIG(1,K*N1)),COLORLIBLUE;
    趋势低:PLOYLINE(DISP=3,ZIG(2,K*N2)),COLORLIBLUE;
    局部低点预选A:=BACKSET(LLV(L,5)<REF(LLV(L,4),1),4);
    局部低点预选B:=BACKSET(局部低点预选A=0 AND REF(局部低点预选A,1)=1,2);
    局部低点预选C:=IF(局部低点预选B=1 AND REF(局部低点预选B,1)=0,-1,0);
    局部高点预选A:=BACKSET(HHV(H,5)>REF(HHV(H,4),1),4);
    局部高点预选B:=BACKSET(局部高点预选A=0 AND REF(局部高点预选A,1)=1,2);
    局部高点预选C:=IF(局部高点预选B=1 AND REF(局部高点预选B,1)=0,1,0);
    缺口判断:=IF(L>REF(H,1),1,IF(H<REF(L,1),-1,0));
    距前高天:=BARSLAST(局部高点预选C=1);
    距前低天:=BARSLAST(局部低点预选C=-1);
    小值周期:=LOWRANGE(L);
    大值周期:=TOPRANGE(H);
    低保留AA:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
    低保留AB:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR LLV(L,距前低天+2)<REF(LLV(L,距前低天+1),1)),-1,0);
    低保留S:=IF((低保留AA=-1 OR 低保留AB=-1) AND L<REF(H,距前高天+1),-1,0);
    预判:=IF((距前低天<4 AND HHV(缺口判断,距前低天)!=1) OR REF(低保留S,距前低天)=0,1,0);
    判断:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND 预判=1 AND 大值周期>REF(小值周期,距前低天+1) AND 大值周期>REF(小值周期,距前低天) AND 大值周期>REF(大值周期,距前高天),1,0);
    高保留A:=IF(局部高点预选C=1 AND REF(距前低天,1)>REF(距前高天,1) AND HHV(H,距前低天+1)>REF(HHV(H,距前低天+1),1),1,0);
    高保留B:=IF(局部高点预选C=1 AND REF(距前低天,1)<=REF(距前高天,1) AND REF(低保留S,距前低天)=-1 AND (距前低天>=4 OR HHV(缺口判断,距前低天)=1),1,0);
    高保留:=IF((高保留A=1 OR 高保留B=1 OR 判断=1) AND H>REF(L,距前低天+1),1,0);
    预判A:=IF((距前高天<4 AND HHV(缺口判断,距前高天)!=1) OR REF(高保留,距前高天)=0,1,0);
    判断A:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND 预判A=1 AND 小值周期>REF(大值周期,距前高天+1) AND 小值周期>REF(大值周期,距前高天) AND 小值周期>REF(小值周期,距前低天),-1,0);
    低保留A:=IF(局部低点预选C=-1 AND REF(距前高天,1)>REF(距前低天,1) AND LLV(L,距前高天+1)<REF(LLV(L,距前高天+1),1),-1,0);
    低保留B:=IF(局部低点预选C=-1 AND REF(距前高天,1)<=REF(距前低天,1) AND (距前高天>=4 OR LLV(缺口判断,距前高天)=-1 OR 判断A=-1),-1,0);
    低保留:=IF((低保留A=-1 OR 低保留B=-1) AND L<REF(H,距前高天+1),-1,0);
    距前高天A:=BARSLAST(高保留=1);
    距前低天A:=BARSLAST(低保留=-1);
    预判X:=IF((距前低天A<4 AND HHV(缺口判断,距前低天A)!=1) OR REF(低保留,距前低天A)=0,1,0);
    判断X:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND 预判X=1 AND 大值周期>REF(小值周期,距前低天A+1) AND 大值周期>REF(小值周期,距前低天A) AND 大值周期>REF(大值周期,距前高天A),1,0);
    高保留XA:=IF(局部高点预选C=1 AND REF(距前低天A,1)>REF(距前高天A,1) AND HHV(H,距前低天A+1)>REF(HHV(H,距前低天A+1),1),1,0);
    高保留XB:=IF(局部高点预选C=1 AND REF(距前低天A,1)<=REF(距前高天A,1) AND REF(低保留,距前低天A)=-1 AND (距前低天A>=4 OR HHV(缺口判断,距前低天A)=1),1,0);
    高保留X:=IF((高保留XA=1 OR 高保留XB=1 OR 判断X=1) AND H>REF(L,距前低天A+1),1,0);
    预判XA:=IF((距前高天A<4 AND HHV(缺口判断,距前高天A)!=1) OR REF(高保留XA,距前高天A)=0,1,0);
    判断XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND 预判XA=1 AND 小值周期>REF(大值周期,距前高天A+1) AND 小值周期>REF(大值周期,距前高天A) AND 小值周期>REF(小值周期,距前低天A),-1,0);
    低保留XA:=IF(局部低点预选C=-1 AND REF(距前高天A,1)>REF(距前低天A,1) AND LLV(L,距前高天A+1)<REF(LLV(L,距前高天A+1),1),-1,0);
    低保留XB:=IF(局部低点预选C=-1 AND REF(距前高天A,1)<=REF(距前低天A,1) AND (距前高天A>=4 OR LLV(缺口判断,距前高天A)=-1 OR 判断XA=-1),-1,0);
    低保留X:=IF((低保留XA=-1 OR 低保留XB=-1) AND L<REF(H,距前高天A+1),-1,0);
    距前高天YA:=BARSLAST(高保留X=1);
    距前低天YA:=BARSLAST(低保留X=-1);
    预判YX:=IF((距前低天YA<4 AND HHV(缺口判断,距前低天YA)!=1) OR REF(低保留X,距前低天YA)=0,1,0);
    判断YX:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND 预判YX=1 AND 大值周期>REF(小值周期,距前低天YA+1) AND 大值周期>REF(小值周期,距前低天YA) AND 大值周期>REF(大值周期,距前高天YA),1,0);
    高保留YXA:=IF(局部高点预选C=1 AND REF(距前低天YA,1)>REF(距前高天YA,1) AND HHV(H,距前低天YA+1)>REF(HHV(H,距前低天YA+1),1),1,0);
    高保留YXB:=IF(局部高点预选C=1 AND REF(距前低天YA,1)<=REF(距前高天YA,1) AND REF(低保留X,距前低天YA)=-1 AND (距前低天YA>=4 OR HHV(缺口判断,距前低天YA)=1),1,0);
    高保留YX:=IF((高保留YXA=1 OR 高保留YXB=1 OR 判断YX=1) AND H>REF(L,距前低天YA+1),1,0);
    预判YXA:=IF((距前高天YA<4 AND HHV(缺口判断,距前高天YA)!=1) OR REF(高保留YXA,距前高天YA)=0,1,0);
    判断YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND 预判YXA=1 AND 小值周期>REF(大值周期,距前高天YA+1) AND 小值周期>REF(大值周期,距前高天YA) AND 小值周期>REF(小值周期,距前低天YA),-1,0);
    低保留YXA:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)>REF(距前低天YA,1) AND LLV(L,距前高天YA+1)<REF(LLV(L,距前高天YA+1),1),-1,0);
    低保留YXB:=IF(局部低点预选C=-1 AND REF(距前高天YA,1)<=REF(距前低天YA,1) AND (距前高天YA>=4 OR LLV(缺口判断,距前高天YA)=-1 OR 判断YXA=-1),-1,0);
    低保留YX:=IF((低保留YXA=-1 OR 低保留YXB=-1) AND L<REF(H,距前高天YA+1),-1,0);
    AAAD:=IF(高保留YX=1 AND 低保留YX=-1 AND H>REF(H,REF(距前高天YA,1)+2),1,IF(高保留YX=1 AND 低保留YX=-1 AND L<REF(L,REF(距前低天YA,1)+2),-1,0));
    极点保留:=IF(AAAD=0,高保留YX+低保留YX,AAAD);
    局部极点:IF(极点保留=-1,L,IF(极点保留=1,H,DRAWNULL)) CIRCLEDOT COLORYELLOW;
    DRAWLINE(极点保留=-1,局部极点,极点保留=1,局部极点,0)COLORLIRED;
    DRAWLINE(极点保留=1,局部极点,极点保留=-1,局部极点,0)COLORYELLOW;
    DD1:=BARSLAST(ABS(极点保留)!=1);{
    DRAWTEXT(极点保留=1,局部极点,'卖'),COLORGREEN;
    DRAWTEXT(极点保留=-1,局部极点,'买'),COLORRED;}
    MA5:MA(CLOSE,5),COLORFF00FF,LINICK2;判:IF(MA5<REF(MA5,1),MA5,DRAWNULL),COLORWHITE,LINICK2;

  • 怎样将通达信缠论买点选股指标公式导入

    匿名用户589评分

    {1.导入公式} 复制上述相关公式-----点‘功能’-----点‘专家系统’-----点‘公式管理’-----点‘条件选股’-----点‘其他类型’-----点‘新建’------粘贴公式-----自己命名公式名称----点‘确定’----OK
    {2.执行选股} 点‘功能’-----点‘选股器’-----点‘条件选股’-----点‘自己已命名的公式’-----点‘加入条件’-----点‘执行选股’----OK {说明:公式无需再设置参数了。直接导入就行}